C64 3rd party mouse issue

Got an issue?
DistantStar001
Member
Member
Posts: 2
Joined: Thu Jun 18, 2020 9:53 pm
Contact:

C64 3rd party mouse issue

Post by DistantStar001 »

So I just got my first mouse for my C64 (made by Computer Technology Inc) and it doesn't (fully) work.

At first, I was afraid that this was an Amiga mouse. I've done that before. Now I have three tank mice and nothing to do with them. I googled the mouse, and apparently, they only made a C64 version (Yay).

So I tested it on a PAL machine with GEOS and it didn't respond to motion, but menus responded when I clicked the left button and the curser goes up when I click the right. That's more than I ever got from the tanks. So I know it's for the C64. I've tried manually moving the wheels but got nothing.

When I opened it, I noticed that the LED and sensors are bent out away from each other at different angles. I don't think this is normal, but I can't be sure. Any suggestions? Also, If I need to replace the sensors or LEDs, what are the part numbers/values that I should be looking for?

Here are some pictures:

Image

Image

Image


DistantStar001
Member
Member
Posts: 2
Joined: Thu Jun 18, 2020 9:53 pm
Contact:

Re: C64 3rd party mouse issue

Post by DistantStar001 »

OK! So progress...

First: It's a Contriver Technology inc. mouse, model M1, not "Computer Technology". God, that text was small!

Second, after another round of Googleing, I was able to learn that the odd angles of the LEDs and sensors were not normal, so I bent them back. Sadly. this has not done any good in function. I didn't see any light coming from the LEDs, but they might be infra-red, that might be normal. In any case, I think I'm on the right track. However, I still don't know what replacement parts I might need so any help is appreciated.
banman
Member
Member
Posts: 130
Joined: Sat Jun 15, 2019 12:21 am
Contact:

Re: C64 3rd party mouse issue

Post by banman »

Hi DistantStar001,


Just saw your post. Looks like a really nice looking mouse.

Something reminded me of a video I watched a while ago relating to a similar issue.

I think it has something to do with the resistor values needing to be readjusted.

Let me think about where I saw this. I get back to you....😁
banman
Member
Member
Posts: 130
Joined: Sat Jun 15, 2019 12:21 am
Contact:

Re: C64 3rd party mouse issue

Post by banman »

Hi DistantStar001,

I think this might give you some ideas.




Let me know how it goes.....
User avatar
Gyro Gearloose
Member
Member
Posts: 369
Joined: Sun Nov 15, 2015 5:20 am
Contact:

Re: C64 3rd party mouse issue

Post by Gyro Gearloose »

Maybe, like the 1351, it has several operating modes that are selected by pressing a button down while powering it up?

Is it supposed to be a proportional mouse? Would GEOS work with a 1351 driver with this mouse?
The price one pays for pursuing any profession, or calling, is an intimate knowledge of its ugly side.
Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 2 guests