1541C unusual "Shorter Board" version - J3?

Disk drives, Monitors, SuperCPU etc.
rmzalbar
Member
Member
Posts: 7
Joined: Wed May 08, 2019 9:06 am
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by rmzalbar » Sat Oct 19, 2019 9:20 am

Well.. I sorted out the electrical issue with a new rectifier, only to find out that it has a bad head. Open between the r/w and center tap (red wire.) it seems this is the usual failure for these mitsumi/newtronics mechanisms.

So I dissected the head under a microscope hoping to learn something, and what I discovered was pretty grim. The wire didn't fail at any of the bond points to the terminals, but down in the coil winding somewhere. I read somewhere that it is suspected the heads weren't sealed properly. Well - that's kind of true in that the bond points of the windings to the PCB are not potted in the silicone, so they could conceivably be attacked where they are soldered, but everything was clean and nothing exposed to air has failed.

It turns out that the wire is very fragile and brittle. It snapped many times with just the barest bending with my tools while gently unwinding to locate the failure. My guess is that it work-hardens over time, and eventually through vibrations coming from mechanical or electromotive forces it snaps. Perhaps if they had used a hard epoxy potting instead of the rather Jell-O-like silicone, we wouldn't having this problem.

The head failure situation is absolutely heartbreaking. We have a good supply of just about every part that tends to fail, except for this.



User avatar
eslapion
Member
Member
Posts: 867
Joined: Mon Jul 20, 2015 10:11 am
Location: Canada
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by eslapion » Sat Oct 19, 2019 3:47 pm

rmzalbar wrote:
Sat Oct 19, 2019 9:20 am
... The wire didn't fail at any of the bond points to the terminals, but down in the coil winding somewhere. I read somewhere that it is suspected the heads weren't sealed properly. Well - that's kind of true in that the bond points of the windings to the PCB are not potted in the silicone, so they could conceivably be attacked where they are soldered, but everything was clean and nothing exposed to air has failed.

It turns out that the wire is very fragile and brittle. It snapped many times with just the barest bending with my tools while gently unwinding to locate the failure. My guess is that it work-hardens over time, and eventually through vibrations coming from mechanical or electromotive forces it snaps. Perhaps if they had used a hard epoxy potting instead of the rather Jell-O-like silicone, we wouldn't having this problem.
Wow! I'm impressed you pushed the investigation to this level. My hat off to your dedication to finding answers on this one.

So it seems the beloved Newtronics mecha has a time bomb built into its R/W head. Recently I paid a visit to a friend and noticed in his Commodore collection was almost only 1541 drives with Alps mecha. Even later generations of 1541C have the Alps fitted in it with a surprising cream white faceplate. Same goes for 1570 single side C128 drives.

Since Newtronics drives were sold starting around 1984, possibly Commodore noted the problem starting to occur a few years later and decided to stop using this mecha. So far no such thing has been seen on the 1571.
Wealth, like happiness, is never attained directly. It comes as a by-product of providing a useful service. -Harland D. Sanders

rmzalbar
Member
Member
Posts: 7
Joined: Wed May 08, 2019 9:06 am
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by rmzalbar » Mon Oct 21, 2019 1:48 am

Yep, I'll probably be adding a 1541-ALPS or a 1571 to my setup. I was sort of hoping that I'd see something in the head that would suggest some preventative action, but nothing comes to mind.

User avatar
Zippy Zapp
Member
Member
Posts: 142
Joined: Tue Jul 21, 2015 6:52 pm
Location: USA
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by Zippy Zapp » Fri Nov 01, 2019 7:30 pm

rmzalbar wrote:
Sat Oct 19, 2019 1:54 am
I've read that the track 0 sensor is disabled from the factory - does this knocking happen even if you cut the disable jumper?
No it does not knock if you set the jumper. I have 2 1541Cs, both with same board and on my second drive, that I got from someone else, I did the jumper to enable the track 0 sensor and it does indeed keep the head from knocking at start up and reset. I am now using it full time to see if I can see any kind of issues.

That said these are different mechanisms and the head bumping is a lot quieter than my other 1541 drives or my Apple II drives. That brings up another tidbit. The Apple drives bump the heads at every power up/reset and they are not known for misalignment that I recall. Speed issues, yes. I have used this 1541C since it was bought new. It has 1000s of hours on it as it was used for a BBS and as a copy slave for a user group. I hope it lasts another 30 years. ;-)
Commodore - Changing the world 8 bits at a time.

User avatar
Gyro Gearloose
Member
Member
Posts: 237
Joined: Sun Nov 15, 2015 5:20 am
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by Gyro Gearloose » Sat Nov 30, 2019 11:21 pm

This is awesome, I just powered up and tested a 1541-II I bought a while ago and I found the same thing, a winding is open in the head.

It is a Mitsumi Newtronics D500 mechanism. I've tried to dissolve the potting compound with "Silicone buster" but it had no effect. Now I'm trying furniture stripper, and it also seems to do nothing.
I'll contact Mitsumi USA if they still have carved stone tablets somewhere that describe these heads and if they have spares somewhere.

Tektronix still had design and engineering specs for the high voltage transformer for a 1950s oscilloscope, so why not?
The price one pays for pursuing any profession, or calling, is an intimate knowledge of its ugly side.

User avatar
Gyro Gearloose
Member
Member
Posts: 237
Joined: Sun Nov 15, 2015 5:20 am
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by Gyro Gearloose » Mon Dec 02, 2019 8:22 pm

Could this be the very same drive?
https://retrohax.net/commodore-1541-flo ... ing-chaos/
Yeah, that's where I am too. Looks like we all end up at the same impasse.
The price one pays for pursuing any profession, or calling, is an intimate knowledge of its ugly side.

User avatar
eslapion
Member
Member
Posts: 867
Joined: Mon Jul 20, 2015 10:11 am
Location: Canada
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by eslapion » Tue Dec 03, 2019 8:42 am

Gyro Gearloose wrote:
Mon Dec 02, 2019 8:22 pm
Could this be the very same drive?
https://retrohax.net/commodore-1541-flo ... ing-chaos/
Yeah, that's where I am too. Looks like we all end up at the same impasse.
The R/W head on Alps mechas seem to fail much less often but they have slightly different characteristics. On boards 250442/446, it is necessary to change jumper J6 depending which one you have.

Would it be possible to use a different type of R/W head to fix the good old Newtronics ?
Wealth, like happiness, is never attained directly. It comes as a by-product of providing a useful service. -Harland D. Sanders

User avatar
Gyro Gearloose
Member
Member
Posts: 237
Joined: Sun Nov 15, 2015 5:20 am
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by Gyro Gearloose » Tue Dec 03, 2019 12:58 pm

I'm looking into it. If I can find a cheap PC 360K drive I'll take a look. The chances of finding a "sled" that could fit into a D500 are pretty slim but who knows. Getting the head assembly out of the sled and putting in a new one seems a bit far-fetched, how can you keep the accurate placement? It's getting a bit crazy.
The price one pays for pursuing any profession, or calling, is an intimate knowledge of its ugly side.

User avatar
Gyro Gearloose
Member
Member
Posts: 237
Joined: Sun Nov 15, 2015 5:20 am
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by Gyro Gearloose » Wed Dec 04, 2019 9:20 am

Here's a new piece of information, a contributor to a vintage Tektronix forum says that the open coil is caused by too high a write current. But it's not the user who sets that, it's selected by engineering at design time. So who is right here? Is it a design flaw in the head by Mitsumi or a design flaw by Commodore?
And why would the Alps drive last longer? Just a slightly different design and it survives the excess current?
How can we ever find out without a data sheet of the Mitsumi head/mechanism?
And could adjusting a resistor extend the life of working Mitsumi drives?
The price one pays for pursuing any profession, or calling, is an intimate knowledge of its ugly side.

User avatar
Gyro Gearloose
Member
Member
Posts: 237
Joined: Sun Nov 15, 2015 5:20 am
Contact:

Re: 1541C unusual "Shorter Board" version - J3?

Post by Gyro Gearloose » Wed Dec 04, 2019 3:46 pm

Ahhh I see now, I have to really dig deeper into the 1541 service manual and take a look at the discrete version of the head amplifier. There are indeed two possible resistance values in the amplifier section for Alps or Newtronics. Very interesting.
The price one pays for pursuing any profession, or calling, is an intimate knowledge of its ugly side.

Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 1 guest